Google AUTO CREATED "Google Tasks" List

mchang's Avatar

mchang

12 Feb, 2021 02:43 AM

Hi Dooster support team-

We just recently sync'd Google with our Dooster.
Strangely, Google auto-created a "GOOGLE Tasks" list in two of our projects (so far we see it in just two projects) -
The 2 projects are "ZZZ-DELETED" and "000-MC New Items"

We tried to delete the tasks and also the TASK LISTs "GOOGLE Tasks" created, so at one point in time there was none of those in Dooster and Google both, but they kept coming back into Dooster in these 2 auto-created "GOOGLE Tasks" list in these 2 projects.

I found an old thread that seems to describe the same problem -- so I don't know if your team already know of a fix for this problem?
Here is the old thread:
https://dooster.tenderapp.com/discussions/problems/64-propegating-in-google-tasks

Please let me know. Again, the problem right now is only seen in 2 PROJECTS (not all PROJECTS -- hopefully they won't start appearing in other PROJECTS too)...

Thanks,
Miranda

  1. 1 Posted by mchang on 12 Feb, 2021 02:53 AM

    mchang's Avatar

    Hi -
    I just found this:
    https://dooster.net/wp/troubleshooting/duplicating-tasks/

    It seems to describe my problems?
    Is it still the recommended "solution" for this?

    Thanks,
    Miranda

  2. 2 Posted by mchang on 12 Feb, 2021 01:24 PM

    mchang's Avatar

    Hi -

    An update on this -- since these "GOOGLE Tasks" auto-created
     by Google was messing up our calendars, we unsync'd Google (all users) to "clean things up" (basically to delete those tasks in both Google and Dooster).

    After we cleand up, we resync'd Google for all users (by checking the box in the Google settings screen in Dooster); when we checked the box, we expected the Google permission to pop up asking for authorization, but that did not happen. Then we went into the Googe settings in GSUITE for 3rd party app access, we also do not see Dooster being authorized. To get Dooster to show up as a 3rd party app authorized for access in Google, we did "sign in with your Google account" on the Dooster side. After that we see in Google GSuite Setting that Dooster is on the list there as an authorized 3rd party app. However, I don't think the Google sync is working -- I think it is no longer syncing. We tested by creating a couple of new, non-recurring tasks, and they are not showing up on the Google side.

    Any idea?

    Thanks,
    Miranda

  3. Support Staff 3 Posted by Sue on 12 Feb, 2021 01:55 PM

    Sue's Avatar

    Hi Miranda

    Yes this is the issue you were seeing https://dooster.net/wp/troubleshooting/duplicating-tasks/

    This is an issue on Google's side - it affects all similar apps

    2) The Google sync is working so Im not sure what's going on there. Is it the old project?

    Thanks

  4. 4 Posted by mchang on 12 Feb, 2021 02:03 PM

    mchang's Avatar

    Thanks Sue, for the prompt reply.
    I will check out that link that you gave.

    As for #2 -- it is NOT an old issue, because we couldn't integrate with Google until now. What I was referring to is that after we TURNED OFF the Google sync to clean up (delete those auto-created tasks), we re-actived Google sync -- so in Dooster, the box is checked, but when we switched it from OFF to ON, the Google authorization screen / page did not pop up for us to authorize Dooster as a 3rd party-app to grant access for by Google (so in Google, we didn't see Dooster as an authorized app to access Google calendar, etc. even after turning sync on on the Dooster side). Therefore, to get that Google screen / page to pop up for us to authorize Dooster as a 3rd party-app to grant access for by Google, we had to do "Sign in with your Google Account" on the Dooster side -- doing that Google did add Dooster onto the authorized 3rd-party app for accessing the Google calendar (we see it under settings on the Google side) . But we still don't see new tasks flowing into Google -- don't new tasks appear in Google pretty quickly if Dooster and Google have been sync'd?

    Thanks,
    Miranda

  5. Support Staff 5 Posted by Sue on 12 Feb, 2021 02:18 PM

    Sue's Avatar

    OK we'll look into this and revert

    Seems there's still a few teething problems around Google sync!

    Thanks

  6. Support Staff 6 Posted by Sue on 13 Feb, 2021 10:11 AM

    Sue's Avatar

    Hi Miranda

    This should be fixed - along with the recurring tasks issues

    it might require a log out/log in via Google

    Let me know how you get on

    Thanks Sue

  7. 7 Posted by mchang on 13 Feb, 2021 06:06 PM

    mchang's Avatar

    Hi Sue -

    We tried and have everyone logged in and out of Google and Dooster, before we turned on GOOGLE SYNC in Dooster for each user.

    So far two users have been able to sync up with GOOGLE (their usernames are ivan and anya). When they turned on that feature in Dooster by checking the box, it did bring up the GOOGLE authentication/permission page asking for authorization.

    However, the other 3 users of ours (their usernames are miranda, ivana, and general) are still unable to sync. When these users turned on that feature in Dooster by checking the box, it did NOT bring up the GOOGLE authentication/permission page asking for authorization.

    Any idea? I made sure that everyone has logged out of Google (all devices) by using the GOOGLE SECURITY page and signed off from all devices before we did this, so am not sure why the 3 users were unable to sync up.

    Let us know.

    Thanks,
    Miranda

  8. Support Staff 8 Posted by John on 13 Feb, 2021 06:30 PM

    John's Avatar

    Hi

    There must be something different about those users.

    Eg what are their permissions?

    How were they invited into dooster?

    That type of thing

    Can you check and advise

    Thanks

  9. 9 Posted by mchang on 13 Feb, 2021 11:32 PM

    mchang's Avatar

    Hi John -

    All users are provided with the same level of permissions and were invited the same way when we started. Now we have waited a few hours longer, 2 out of the 3 that I mentioned couldn't SYNC with GOOGLE are now able to SYNC too! When they turned on that feature in Dooster by checking the box, it did bring up the GOOGLE authentication/permission page asking for authorization, so those 2 are all set.

    Now just leaving with 1 user (username GENERAL) still unable to sync. My guess is for some reason it takes a bit of time for that log in/out of Google to kick in maybe? We will just wait a day or two and see if the final 1 user will be able to sync up Google later on. I will let you know.

    Thanks again for all the help that your team put in to make Dooster work the way our team would like it to. Really appreciate it the hard work.

    Thanks,
    Miranda

  10. Support Staff 10 Posted by Sue on 14 Feb, 2021 09:56 AM

    Sue's Avatar

    Hi Miranda

    One of our guys reported re this

    I followed the ticket as well. I was able to manually sync Miranda's calendar, so I guess her account should be ok, as she mentioned further down the ticket. But for the problematic account, i.e. the one named "GENERAL", when I try to sync manually, I get an error that Google Account Setting for this username does not exist.

    Maybe the checkbox is not selected in the Google Settings? Or maybe the Google Auth Screen has not reappeared for this account?

    Thanks

    Sue

  11. 11 Posted by mchang on 14 Feb, 2021 03:51 PM

    mchang's Avatar

    Thanks Sue.

    Correct - the user GENERAL is still not sync'd with Google, and as your guy mentioned -- I think it is because when that Google checkbox is selected in Dooster, it did not bring up that Google Auth Screen still. Since this user for us is just a general user (w/ no tasks assigned), it is not an urgent matter for us and we will simply let GENERAL sits for a few days and see if the Google Auth Screen reappears (like it did for the other users of ours).

    We no longer have issues with any other users with GOOGLE SYNC (other than the problem of some tasks missing on the Google calendar, as I described in my other thread).

    Thanks,
    Miranda

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • ZZZ-DELETED_GOOGLE_TASKS.jpg 62.3 KB
  • 000-MC_New_Items_GOOGLE_TASKS.jpg 103 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac